blog.icewolf.ch

Let's talk about IT!
posts - 1334, comments - 295, trackbacks - 0

My Links

Archives

Post Categories

icewolf

Windows Server 2016 Cumulative Update does not install on Exchange 2016 Server

Hallo zusammen,

Bereits letzten Monat hatte ich auf meinem Exchange 2016 Server auf Windows Server 2016 Probleme beim installieren vom "2018-06 Cumulative Update for Windows Server". Das Update wurde zwar installiert, aber nach dem Reboot wurde das Update wieder angeboten. Da war also etwas schiefgelaufen.

Mit dem "2018-07 Cumulative Update for Windows Server" war dieses Problem immer noch vorhanden und ich musste mich genauer damit auseinandersetzen. Schliesslich gehört ein gepatchtes System zu den Grundvoraussetzungen.

Also habe ich das Update heruntergeladen und manuell installiert.

Nach dem Reboot wird das Update fertig installiert. Dort kommt es zu einem Fehler und es wird ein Revert eingeleitet.

Folgende Events sind im Eventlog danach sichtbar.

Eventid: 20
Level: Error
Source: WindowsUpdateClient
Description: Installation Failure: Windows failed to install the following update with error 0x800F0922: Feature Pack for Windows (KB4284880)

Eventid: 7023
Level: Error
Source: Service Control Manager
Description: The Update Orchestrator Service for Windows Update Service terminated with the following error: The class is configured to run as a Security id diffrent from the Caller
Eventid: 219
Level: Warning
Source: Kernel-PnP
Description: The driver \Driver\WudRD failed to load for the devices SWD\WPDBUSENUM\{78953bf1-53dc-11e8-8414-806e6f6e6963}#0000000008100000

Irgendwo habe ich folgenden Tipp gelesen. Gleich vorweg - das hat nichts gebracht. Das Update wurde nach dem Reboot wieder aufgrund eines Fehlers deinstalliert

DISM.exe /Online /Cleanup-image /Restorehealth

Zum letzten Eventlog Eintrag habe ich dann folgende Info gefunden. Anscheinend handelt es sich um ein Timing Issue. Man soll den Service "Windows Driver Foundation" auf Automatic stellen. Leider hat auch das nichts gebracht.

https://social.technet.microsoft.com/Forums/en-US/48fb7856-feb0-4732-819f-245f7efba053/event-id-219-quotthe-driver-driverwudfrd-failed-to-load-for-the-devicequot?forum=win10itprogeneral

Aber da ich nun wusste, dass es ein Timing Problem ist, habe ich mal die Exchange Services deaktiviert. So würde das starten weniger lange dauern und allfällige Timeouts umgangen werden.

Mit dem folgenden Befehl habe ich mir alle Exchange Services und deren StartType herausgeschrieben. Habe das dann in einem TXT File notiert.

Get-Service -name MSE* | ft status, Name, StartType,Displayname

Mit dem folgenden Befehl habe ich die Exchange Services deaktiviert

Get-Service -name MSE* | Set-Service -StartupType Disabled

Das hat schliesslich dann funktioniert und ich konnte hinterher die Exchange Services wieder auf Automatic stellen und starten.

Das ganze hat mich extrem viel Zeit gekostet herauszufinden. Hoffe das hilft dem einen oder anderen von euch, wenn er dasselbe Problem hat.

Grüsse
Andres Bohren

Print | posted on Monday, July 16, 2018 8:20 AM | Filed Under [ Exchange Windows ]

Powered by:
Powered By Subtext Powered By ASP.NET