blog.icewolf.ch

Let's talk about IT!
posts - 1314, comments - 295, trackbacks - 0

My Links

Archives

Post Categories

icewolf

ESXi Upgrade from 6.0 to 6.7 on HP ML350e Gen8

Hallo zusammen,

ESXi 6.7 ist ja bereits seit Mitte April verfügbar. Obwohl mein Server ein "HP ProLiant ML350e Gen8" nicht mehr in der Kompitabilitätsliste aufgeführt ist, habe ich es auf einen Versuch ankommen lassen. Als Vorsichtsmassnahme habe ich einfach jeweils eine der RAID1 Harddisks gezogen.

Download ISO ESXi 6.5
Danach habe ich das ISO Image mit UNetbootin auf einen bootbaren USB Stick kopiert.

In VMware ESXi 6.0 habe ich alle Virtuellen Machinen gestoppt

Danach habe ich den Server neu gestartet.

Beim booten mit F11 ins Bootmenü

Beim Bootmenü die Option "One Time Boot to USB DriveKey"

Dann den ESXi Eintrag wählen und Enter drücken

Nun startet der ESXI installer

Hui eine ziemlich lange Liste an Abhängigkeiten, welche da nicht erfüllt ist. Das klappt also nicht.

Nächste Idee das HP Custom Image. Leider gibt es das nur noch für den HP G9 Server. Naja, mal sehen ob es trotzdem damit klappt.

https://www.hpe.com/ch/de/servers/hpe-esxi.html

  • Also wieder das ESXi Image mit Unetbootin auf einen USB Key kopiert.
  • Alle VM's getoppt
  • Server neu gestartet
  • Mit F11 ins Bootmenü
  • Den USB Key zum Booten ausgewählt

Damit wurde dann nur noch eine Abhängigkeit nicht mehr erfüllt:

Mellanox_bootbank_net-mst_2.0.0.0-10EM.550.0.0.472560

Das musste ich erstmal ein bisschen Recherche machen. Habe dann aber jemand gefunden, der das selbe Problem beim Upgrade von ESXi 6.0 auf 6.5 hatte. 

https://www.stephenwagner.com/2016/12/07/vmware-vsphere-6-5-conflicting-vibs-when-upgrading-esxi-6-0-to-6-5/

Mit dem folgenden Befehl kann alle Software mit dem Namen "Mellanox" aufgelistet werden.

esxcli software vib list | grep Mellanox

Mit folgendem Befehl kann man sich die Netzwerkadapter und deren Treiber anzeigen lassen. Ich habe also "igp" treiber und brauche die Mellanox Treiber gar nicht.

esxcli network nic list

Also weg mit den net-mst Treibern

esxcli software vib remove -n net-mst

Danach konnte ich problemlos auf ESXi 6.7 updaten.

Allerdings noch einen kleinen Hinweis. Wenn ihr den VMware Unlocker 2.0.6 installiert habt, dann starten eure Machinen nicht. Also deinstallieren und danach nochmals durchbooten.

Grüsse
Andres Bohren

Print | posted on Saturday, July 21, 2018 8:56 PM | Filed Under [ Virtualisation ]

Powered by:
Powered By Subtext Powered By ASP.NET