blog.icewolf.ch

Let's talk about IT!
posts - 1515, comments - 295, trackbacks - 0

My Links

Archives

Post Categories

icewolf

Hybrid Agent Setup - Error Register Hybrid Agent

Hallo zusammen,

Hatte heute mal wieder ein Problem mit dem Hybrid Agent ein Problem. Da das öfters vorzukommen schein, blogge ich mal darüber. Damit ihr beim selben Fehler nicht ewig nach der Ursache suchen müsst.

Habe dann mal im Hybrid Configuration Wizard Logfile nachgeschaut.

C:\Users\<Username>\AppData\Roaming\Microsoft\Exchange Hybrid Configuration

Ich bin als Global Admin eingeloggt - also an zu wenig Rechten kann es ja nicht liegen.

2020.05.15 08:45:07.329         10332 [Client=UX, fn=SendAsync, Thread=14] START PATCH https://graph.microsoft.com/edu/46bbad84-29f0-4e03-8d34-f6841a5071ad/applications/1059d41d-3a98-40c9-9c1b-3c7016a8aed1 {"onPremisesPublishing":{"applicationServerTimeout":"Default","applicationType":"microsoftapp","externalAuthenticationType":"passthru","externalUrl":"https://1059d41d-3a98-40c9-9c1b-3c7016a8aed1.resource.mailboxmigration.his.msappproxy.net:443/","internalUrl":"https://icesrv06.corp.icewolf.ch:443/","isOnPremPublishingEnabled":true,"isTranslateHostHeaderEnabled":false,"isTranslateLinksInBodyEnabled":false,"singleSignOnSettings":null,"verifiedCustomDomainCertificatesMetadata":null,"verifiedCustomDomainKeyCredential":null,"verifiedCustomDomainPasswordCredential":null}}
2020.05.15 08:45:07.863         10333 [Client=UX, fn=SendAsync, Thread=14]
                                      FINISH Time=534.0ms Results=Forbidden {
                                        "error": {
                                          "code": "NotAdminRoleNoEnoughCustomPermission_UnauthorizedAccess",
                                          "message": "Unauthorized Access.",
                                          "innerError": {
                                            "request-id": "2c46ee3d-c356-47d3-9f20-c45b3252d218",
                                            "date": "2020-05-15T08:44:11"
                                          }
                                        }
                                      }
2020.05.15 08:45:07.871         10407 [Client=UX, Thread=14] Updating Local Client Configuration File
2020.05.15 08:45:07.945         10341 [Client=UX, Page=HybridConnectorInstall, Step=ConfigOrgRoute, Thread=14] FINISH Time=657.0ms Results=Failed

Das selbe Problem gab es schon am 20/21.04.2020. Ab dem 22.04.2020 hat es dann wieder funktioniert.

Ich habe ein Microsoft Ticket eröffnet. Mal sehen wie lange die Behebung dieses mal dauert.

Die Versionsnummer vom Exchange wird im Hybrid Configuration Wizard korrekt erkannt (oben rechts rot markiert). Allerdings ist das nicht das CU11 sonder das CU16. Wie man hier entnehmen kann.

https://docs.microsoft.com/en-us/exchange/new-features/build-numbers-and-release-dates?view=exchserver-2019

Grüsse
Andres Bohren

Print | posted on Friday, May 15, 2020 4:16 PM | Filed Under [ O365 ]

Powered by:
Powered By Subtext Powered By ASP.NET